获取证书失败,请到 https://www.hijk.pw 反馈



  • 由于出现这个错误
    2020/07/20 14:12:00 [Warning] failed to handler mux client connection > v2ray.com/core/proxy/vmess/outbound: connection ends > v2ray.com/core/proxy/vmess/outbound: failed to read header > v2ray.com/core/proxy/vmess/encoding: failed to read response header > websocket: close 1000 (normal)
    我清空了服务器,重新安装,但是安装过程中提示获取证书失败

    An unexpected error occurred:
    pkg_resources.ContextualVersionConflict: (cryptography 2.3 (/usr/lib64/python3.6/site-packages), Requirement.parse('cryptography>=2.8'), {'PyOpenSSL'})
    Please see the logfile '/tmp/tmp1qxxc38r/log' for more details.
    获取证书失败,请到 https://www.hijk.pw
    我按教程更换了两个主机名尝试,都是正数失败。应该怎么弄了



  • @mozhua pip3 install cryptograhpy,然后再试试



  • pip3 install cryptograhpy 这个是什么意思,我百度不到



  • [root@11*-2***-&**4 ~]# pip3 install cryptograhpy
    WARNING: Running pip install with root privileges is generally not a good idea. Try pip3 install --user instead.
    Collecting cryptograhpy
    Could not find a version that satisfies the requirement cryptograhpy (from versions: )



  • 安装v2ray...
    Latest version v4.26.0 is already installed.
    /dev/fd/63: line 172: ntpdate: command not found
    v2ray安装成功!
    Warning: ALREADY_ENABLED: http
    success
    Warning: ALREADY_ENABLED: https
    success
    Warning: ALREADY_ENABLED: 443:tcp
    success
    success
    Last metadata expiration check: 0:29:30 ago on Mon 20 Jul 2020 05:30:19 PM CST.
    Package nginx-1:1.14.1-9.module_el8.0.0+184+e34fea82.x86_64 is already installed.
    Dependencies resolved.
    Nothing to do.
    Complete!
    WARNING: Running pip install with root privileges is generally not a good idea. Try pip3 install --user instead.
    Requirement already satisfied: certbot in /usr/local/lib/python3.6/site-packages
    Requirement already satisfied: zope.component in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: acme>=1.6.0 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: ConfigArgParse>=0.9.3 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: pytz in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: cryptography>=1.2.3 in /usr/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: josepy>=1.1.0 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: pyrfc3339 in /usr/local/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: parsedatetime>=1.3 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: zope.interface in /usr/local/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: configobj in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: setuptools in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: distro>=1.0.1 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: zope.deferredimport>=4.2.1 in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.deprecation>=4.3.0 in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.event in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.hookable>=4.2.0 in /usr/local/lib64/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: PyOpenSSL>=0.15.1 in /usr/local/lib64/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: requests-toolbelt>=0.3.0 in /usr/local/lib/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: requests[security]>=2.6.0 in /usr/lib/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: six>=1.9.0 in /usr/lib/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: idna>=2.1 in /usr/lib/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: asn1crypto>=0.21.0 in /usr/lib/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: cffi!=1.11.3,>=1.7 in /usr/lib64/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: zope.proxy in /usr/local/lib64/python3.6/site-packages (from zope.deferredimport>=4.2.1->zope.component->certbot)
    Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python3.6/site-packages (from requests[security]>=2.6.0->acme>=1.6.0->certbot)
    Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python3.6/site-packages (from requests[security]>=2.6.0->acme>=1.6.0->certbot)
    Requirement already satisfied: pycparser in /usr/lib/python3.6/site-packages (from cffi!=1.11.3,>=1.7->cryptography>=1.2.3->certbot)
    An unexpected error occurred:
    pkg_resources.ContextualVersionConflict: (cryptography 2.3 (/usr/lib64/python3.6/site-packages), Requirement.parse('cryptography>=2.8'), {'PyOpenSSL'})
    Please see the logfile '/tmp/tmpqcavue2v/log' for more details.
    获取证书失败,请到 https://www.hijk.pw 反馈



  • @hijk [root@11*-2***-&**4 ~]# pip3 install cryptograhpy
    WARNING: Running pip install with root privileges is generally not a good idea. Try pip3 install --user instead.
    Collecting cryptograhpy
    Could not find a version that satisfies the requirement cryptograhpy (from versions: )



  • @mozhua pip3 uninstall cryptography,然后pip3 install cryptography,再运行一键脚本



  • @hijk 不行还是这个获取证书失败
    BBR模块已安装
    安装v2ray...
    Latest version v4.26.0 is already installed.
    /dev/fd/63: line 172: ntpdate: command not found
    v2ray安装成功!
    Warning: ALREADY_ENABLED: http
    success
    Warning: ALREADY_ENABLED: https
    success
    Warning: ALREADY_ENABLED: 443:tcp
    success
    success
    Last metadata expiration check: 2:54:35 ago on Tue 21 Jul 2020 05:31:48 AM CST.
    Package nginx-1:1.14.1-9.module_el8.0.0+184+e34fea82.x86_64 is already installed.
    Dependencies resolved.
    Nothing to do.
    Complete!
    WARNING: Running pip install with root privileges is generally not a good idea. Try pip3 install --user instead.
    Requirement already satisfied: certbot in /usr/local/lib/python3.6/site-packages
    Requirement already satisfied: distro>=1.0.1 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: parsedatetime>=1.3 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: zope.component in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: zope.interface in /usr/local/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: configobj in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: cryptography>=1.2.3 in /usr/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: pyrfc3339 in /usr/local/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: pytz in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: acme>=1.6.0 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: setuptools in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: ConfigArgParse>=0.9.3 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: josepy>=1.1.0 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: zope.deferredimport>=4.2.1 in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.deprecation>=4.3.0 in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.hookable>=4.2.0 in /usr/local/lib64/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.event in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: idna>=2.1 in /usr/lib/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: asn1crypto>=0.21.0 in /usr/lib/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: six>=1.4.1 in /usr/lib/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: cffi!=1.11.3,>=1.7 in /usr/lib64/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: requests-toolbelt>=0.3.0 in /usr/local/lib/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: requests[security]>=2.6.0 in /usr/lib/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: PyOpenSSL>=0.15.1 in /usr/local/lib64/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: zope.proxy in /usr/local/lib64/python3.6/site-packages (from zope.deferredimport>=4.2.1->zope.component->certbot)
    Requirement already satisfied: pycparser in /usr/lib/python3.6/site-packages (from cffi!=1.11.3,>=1.7->cryptography>=1.2.3->certbot)
    Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python3.6/site-packages (from requests[security]>=2.6.0->acme>=1.6.0->certbot)
    Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python3.6/site-packages (from requests[security]>=2.6.0->acme>=1.6.0->certbot)
    An unexpected error occurred:
    pkg_resources.ContextualVersionConflict: (cryptography 2.3 (/usr/lib64/python3.6/site-packages), Requirement.parse('cryptography>=2.8'), {'PyOpenSSL'})
    Please see the logfile '/tmp/tmpj6qklioj/log' for more details.
    获取证书失败,请到 https://www.hijk.pw 反馈



  • http://tast.yiwuyunhan.xyz/ 这个是我换过的主机名 打开是500 Internal Privoxy Error ,
    有几个V2正常使用的主机名打开是 504 Gateway Time-out



  • @mozhua 500说明配置错了或者节点挂了

    504说明网站挂了



  • 刚我把 服务器时间手动改成世界时间,好了
    这个错误,没有了
    2020/07/20 14:12:00 [Warning] failed to handler mux client connection > v2ray.com/core/proxy/vmess/outbound: connection ends > v2ray.com/core/proxy/vmess/outbound: failed to read header > v2ray.com/core/proxy/vmess/encoding: failed to read response header > websocket: close 1000 (normal)



  • @hijk 我新建了ip 新建了域名,重装V2,系统是CentOS的8.2(64位)
    Error: Unable to find a match: ntpdate
    BBR模块已安装
    安装v2ray...
    Latest version v4.26.0 is already installed.
    /dev/fd/63: line 172: ntpdate: command not found
    v2ray安装成功!
    Warning: ALREADY_ENABLED: http
    success
    Warning: ALREADY_ENABLED: https
    success
    success
    success
    Last metadata expiration check: 1:42:28 ago on Tue 21 Jul 2020 08:56:24 AM CST.
    Package nginx-1:1.14.1-9.module_el8.0.0+184+e34fea82.x86_64 is already installed.
    Dependencies resolved.
    Nothing to do.
    Complete!
    WARNING: Running pip install with root privileges is generally not a good idea. Try pip3 install --user instead.
    Requirement already satisfied: certbot in /usr/local/lib/python3.6/site-packages
    Requirement already satisfied: pytz in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: josepy>=1.1.0 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: distro>=1.0.1 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: ConfigArgParse>=0.9.3 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: pyrfc3339 in /usr/local/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: setuptools in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: zope.interface in /usr/local/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: acme>=1.6.0 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: cryptography>=1.2.3 in /usr/lib64/python3.6/site-packages (from certbot)
    Requirement already satisfied: parsedatetime>=1.3 in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: configobj in /usr/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: zope.component in /usr/local/lib/python3.6/site-packages (from certbot)
    Requirement already satisfied: PyOpenSSL>=0.13 in /usr/local/lib64/python3.6/site-packages (from josepy>=1.1.0->certbot)
    Requirement already satisfied: six>=1.9.0 in /usr/lib/python3.6/site-packages (from josepy>=1.1.0->certbot)
    Requirement already satisfied: requests[security]>=2.6.0 in /usr/lib/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: requests-toolbelt>=0.3.0 in /usr/local/lib/python3.6/site-packages (from acme>=1.6.0->certbot)
    Requirement already satisfied: idna>=2.1 in /usr/lib/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: asn1crypto>=0.21.0 in /usr/lib/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: cffi!=1.11.3,>=1.7 in /usr/lib64/python3.6/site-packages (from cryptography>=1.2.3->certbot)
    Requirement already satisfied: zope.deprecation>=4.3.0 in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.hookable>=4.2.0 in /usr/local/lib64/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.deferredimport>=4.2.1 in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: zope.event in /usr/local/lib/python3.6/site-packages (from zope.component->certbot)
    Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python3.6/site-packages (from requests[security]>=2.6.0->acme>=1.6.0->certbot)
    Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python3.6/site-packages (from requests[security]>=2.6.0->acme>=1.6.0->certbot)
    Requirement already satisfied: pycparser in /usr/lib/python3.6/site-packages (from cffi!=1.11.3,>=1.7->cryptography>=1.2.3->certbot)
    Requirement already satisfied: zope.proxy in /usr/local/lib64/python3.6/site-packages (from zope.deferredimport>=4.2.1->zope.component->certbot)
    An unexpected error occurred:
    pkg_resources.ContextualVersionConflict: (cryptography 2.3 (/usr/lib64/python3.6/site-packages), Requirement.parse('cryptography>=2.8'), {'pyOpenSSL', 'PyOpenSSL'})
    Please see the logfile '/tmp/tmpo_hxl5he/log' for more details.
    获取证书失败,请到 https://www.hijk.pw 反馈



  • @hijk CentOS系统 8.2 会提示证书失败,换CentOS系统8.1就没有提示了



  • @mozhua 8.2没有测试过,可能是新出现的问题


登录后回复